ITHitEditDocumentOpener sous linux

Topic created · 17 Posts · 76 Views
  • Bonjour,
    Certains de nos utilisateurs ont un poste sous Linux (Ubuntu) or quand nous tentons d'installer le Paquet avec l'extension.deb, nous avons une erreur sur l'installation de setuptools.
    Avez-vous une solution ?
    D'avance merci.

    Cordialement

  • La version v5.15.5434.0 (July 14, 2020) d'ITHIt est censée corriger un bug de l'extension sous Firefox Ubuntu. Cette version est incluse dans GoFAST 3.8.1 qui sera déployée chez nos clients dans une quinzaine de jours.

    Néanmoins il n'est pas sûr que cela corresponde à votre problème. Pourriez-vous indiquer la version d'Ubuntu et le message d'erreur ?

    Merci

  • La version d'ubuntu est 18.04.5
    L'erreur intervient lors de l'installation du paquet .deb dont je vous joint une capture ci-dessous.
    Erreur installation ITHit Ubuntu.png

    Merci pour votre aide.

    Cordialement

  • Bonjour @MauryESEA,

    Pourriez-vous essayer la commande :

    apt list --installed | grep setuptool
    

    Il semblerait que le paquet setuptools (python-setuptools ou python3-setuptools) soit manquant. Étrangement ITHit ne semble pas capable de l'installer en dépendance.

    Je viens de faire le test sur mon PC et l'installation fonctionne bien avec ce paquet.

    Merci d'avance !

    Cordialement,

  • Bonjour @jlemangarin,
    Merci pour votre réponse.
    En effet, en installant le paquet python-setuptools via apt, l'installation de ITHit se déroule normalement.
    Par contre, bien qu'ayant installé l'extension dans Firefox après l'installation du paquet, cela ne fonctionne pas. J'ai toujours la fenêtre m'invitant à télécharger le paquet Gdeb.

    Y a-t-il des choses particulière à faire ?
    Cordialement

    Version Firefox : 80.0.1 (64bits)
    Version python-setuptools : 39.0.1-2
    Version ithiteditdocopenerprotocolv10 : 5.14.5337.0

  • @MauryESEA à mon sens cela correspond à mon message https://community.ceo-vision.com/post/1152
    Pouvez-vous faire un test avec Chrome

  • Bonjour,
    j'ai fait un test avec chrome. Il me présente une boite de dialogue proposant d'ouvrir xdg-open, mais ensuite, rien ne se passe.
    xdg-open.png

  • Bonjour @MauryESEA,

    Pourriez-vous vérifier l'existance et le contenu du fichier /usr/share/applications/ithiteditdocopenerprotocolv10.desktop ?

    Merci d'avance !

    Cordialement,

  • Bonjour @jlemangarin ,
    Oui le fichier est présent. Voici son contenu:
    Capture d’écran 2020-09-14 113604.png

  • Bonjour @MauryESEA,

    Mes excuses pour mon retour tardif, pourriez-vous essayer de désinstaller le paquet...

    apt-get remove ithiteditdocopenerprotocolv10
    

    ...et d'installer cette version ?

    Merci d'avance !

    Cordialement,

  • Bonjour et bonne année à toute l'équipe CEO,
    Je reprends ce sujet car à ce jour, nous n'avons toujours pas réussi à faire fonctionner ce composant sur nos machines Linux. Comme échangé avec Mme Yevtykova, nous pourrions vous proposer de vous donner la main sur une de nos machines Linux pour voir comment résoudre ce souci. Pourriez-vous me donner vos disponibilités afin de programmer ceci ?

    D'avance Merci.

  • Bonjour @MauryESEA,

    Il y a pour le moment un problème de toute manière bloquant que nous essayons de résoudre avec l'éditeur d'ITHit Document Opener.

    Pour faire simple : ITHit Document Opener utilise davfs2 pour faire un montage réseau vers GoFAST et ouvrir un document, le problème est que ITHit Document Opener essaie de faire un point de montage vers le dossier dans lequel se trouve le document, exemple :

    https://gofast.ceo-vision.com:443/TICKET_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/alfresco/webdav/Sites/_Groups/_Groupes CEO-Vision/_Groupe XYZ.....
    

    En utilisant un nom de dossier reprenant tout le chemin :

    /home/jleman/.tmp/webdav/webdavhttps:__gofast.ceo-vision.com:443_TICKET_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx_alfresco_webdav_Sites__Groups__Groupes CEO-Vision__Groupe XYZ............
    

    Et quand davfs2 crée son dossier de cache, il fait la concaténation de ces deux paramètres, ce qui nous donne quelque chose comme :

    /var/cache/davfs2/gofast.ceo-vision.com-TICKET_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx-alfresco-webdav-Sites-_Groups-_Groupes CEO-Vision-_Groupe XYZ+home-jleman-.tmp-webdav-webdavhttps:__gofast.ceo-vision.com:443_TICKET_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx_alfresco_webdav_Sites__Groups__Groupes CEO-Vision__Groupe XYZ_+root
    

    La limite de taille du nom d'un dossier étant de 255 caractères, les deux éditeurs (ITHit et davfs2) dans la conception de leur application risquent de dépasser la limite (ce qui est largement le cas ici).

    Après mon ouverture de bug chez ITHit, ils ont eux même ouvert un bug chez davfs2 : http://savannah.nongnu.org/bugs/?59548 mais ce bug est déjà remonté chez eux depuis 2014 et ils semblent n'avoir jamais pris aucune disposition et éviter le sujet...

    Je suis entrain d'essayer de travailler avec ITHit qui sont beaucoup plus enclin à comprendre nos problématiques (le support payant aidant certainement) pour résoudre ce problème, je leur ai demandé en plus de mes propositions de me fournir les sources de l'extension pour pouvoir y faire un workaround au cas ou ils mettraient du temps à produire un correctif.

    Je vous tiens au courant dés que j'ai du nouveau !

    Cordialement,

  • Bonjour,
    Je vous remercie pour cette réponse. Merci de votre aide. Cordialement

  • Bonjour @MauryESEA,

    En attendant un correctif de la part d'ITHit, j'ai patché leur librairie et l'édition en ligne fonctionne maintenant correctement sur mon poste.

    Pourriez-vous essayer à nouveau de désinstaller ITHit Document Opener :

    apt-get remove ithiteditdocopenerprotocolv10
    

    Puis d'installer cette version ?

    Dans le cas ou vous rencontreriez encore des problèmes, pourriez-vous me transmettre le contenu du fichier '~/.it_hit/IT_Hit_Edit_Doc_Opener_(Protocol_v10)_DAV10_v5.16.5463.0.log'

    Merci d'avance !

    Cordialement,

  • Bonjour,
    J'ai réussi à faire fonctionner ItHit Sur un Linux. Par contre, avec Libreoffice, je ne peux ouvrir qu'en lecture seule avec le message suivant:
    1ca339fe-c787-44f1-9a04-a71bb426a223-image.png
    J'ai cherché pour résoudre un éventuel problème de droit, mais je n'ai pas trouvé.

    Cordialement

  • Bonjour @MauryESEA,

    Merci pour votre retour !

    Pourriez-vous me transmettre le contenu de votre de fichier '~/.it_hit/IT_Hit_Edit_Doc_Opener_(Protocol_v10)_DAV10_v5.16.5463.0.log' (jerome.leman@ceo-vision.com si vous ne souhaitez pas le dévoiler).

    Merci d'avance !

    Cordialement,

  • Voici la configuration LibreOffice pour contourner ce problème (en attendant mieux) :

    • Ouvrir LibreOffice
    • Aller dans les Options avancés de LibreOffice (Outils/Tools => Options => LibreOffice => Avancé/Advanced) puis ouvrir l'éditeur de configuration avancé (bouton en bas à droite)
      62e72920-f4d4-47cd-bbb7-e61d42d25537-image.png
    • Chercher avec la barre de recherche l'option 'UseLocking' et passer la valeur à 'false' en double cliquant dessus
      8183f7d5-fffd-4a2e-a728-977be69b407c-image.png

    Vous pouvez ensuite appliquer et relancer une édition en ligne, cela devrait fonctionner.

    Cordialement,

Log in to reply