"Erreur interne du chargement des bibliothèques SSL" Office2010/Windows7 utilise des protocoles non sécurisés

  • Depuis la dernière version GoFAST (GoFAST 3.5.2) nous interdisons les protocoles ayant des failles de sécurité connues (plus particulièrement TLSv1.0 et TLSv1.1). Le protocole TLSv1.0 est d'ailleurs interdit par la norme de paiement bancaire PCI-DSS.

    Par contre sous Windows7/Office 2010, Microsoft laisse l'utilisation de ces protocoles non sûrs par défaut, ceci étant refusé par GoFAST et ce qui empêche l'ouverture sous Office 2010 "L’application a rencontré une erreur interne du chargement des bibliothèques SSL."

    La procédure Microsoft pour se mettre en conformité sécurité est ici: https://support.microsoft.com/fr-fr/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi

    Il suffit de lancer le petit exécutable au paragraphe "Facile à corriger"

    On ne peut que constater avec effarement la légèreté de Microsoft concernant Windows7 sur un tel sujet de sécurité, où un protocole avec des failles est laissé par défaut.

  • @cpotter J'en profite pour réaffirmer que le non remplacement d'Office (surtout 2010) et l'utilisation d'OnlyOffice inclut dans GoFAST est une excellente stratégie. Cela permet d'importantes économies et évite d'avoir à installer un logiciel sur le PC, un simple navigateur suffit. Et bien sûr cela permet la co-édition à plusieurs faisant gagner beaucoup de temps.

  • Je rajouterais que ce problème se traduit par l'impossibilité d'ouvrir en édition en ligne un fichier depuis GoFAST avec sa Suite Office de Microsoft.
    Pour corriger le problème de Microsoft, il faut donc absolument suivre les instructions laissées par @cpotter.